Problemas con la misión programada con el Dron "Hornero" en Pergamino


#1

Hola a tod@s,
Escribo en nombre del equipo de Ecofisiología de INTA Pergamino ya que hemos tenido un problema para realizar la misión que le cargamos a nuestro drone “Hornero”. Brevemente, resulta que hicimos los pasos que a continuación detallaré y cuando activamos la misión desde la computadora el drone empezó a bajar y perdimos el control del mismo mediante la radio.

Procedimiento que seguimos para la realización de la misión:

  1. Primero cargamos un archivo KLM en la versión del MISSION PLANNER y dibujamos el polígono tal como nos explicaron en el curso
  2. Del polígono, generamos una misión automática usando el AUTO WP
    image
  3. En el AUTO WP, agregamos la cámara CANON ELPH 180 cargando una imagen en la parte de CONFIGURACIÓN DE CAMARA y en la parte de SIMPLE configuramos todo de la siguiente manera
    image
    Entre lo que configuramos, pusimos a 30 m de altitud para el drone y el angulo del drone lo pusimos en perpendicular a la dirección del viento que tuvimos el día de la misión. Además, chequeamos que el tiempo de duración fuera menor a 10 min y los tiempos entre foto y foto sean mayores a 2 min tal como habían indicado Paz y Gustavo.
  4. Luego de eso le dimos aceptar y obtuvimos el siguiente plan de vuelo:
    image .
    image
  5. Una vez terminado eso, salvamos la misión y pasamos a la etapa de enviarle la misión al drone. Para ello conectamos el drone a la computadora y una vez realizado apretamos en la parte escribir WPs donde suponemos que la misión había sido enviada a la computadora
  6. Ya con el drone en funcionamiento, luego de chequear todos los ítems mensionado en la guía cuando después de pasarlo a modo LOITER enviamos la orden de que arrancara la misión al drone, el mismo empezó a bajar y no respondía a los controles de la radio. La manera que nosotros le indicamos que tenía que seguir el plan de vuelo fue la siguiente:
    image
    EXTRAS: Una de las cosas que probamos fue sacarle el primer TAKEOFF de la misión pero esto tampoco funcionó.

Desde ya muchas gracias

Espero que alguien en el foro nos pueda ayudar a entender en que estaríamos fallando

Saludo atte

Facundo Curin


#2

Hola Facundo! Le echo una mirada con detalle a esto y les escribo por aquí luego :slight_smile:


#3

Hola de nuevo,

Charlamos con Gustavo y lo que vemos a primera vista son dos opciones (y/o): (1) la misión no se envió exitosamente al Hornero, (2) viendo el último pantallazo, no ejecutaron correctamente el comando para activar el vuelo autónomo.

En relación a la opción (1), cuando el drone en puesto en modo auto y no tiene una misión (o WPs guardados), automaticamente entra en modo RTL. Ver estos posteos como referencia https://discuss.ardupilot.org/t/copter-falls-from-sky-after-mission-start-action-excuted/20552/4 y https://discuss.ardupilot.org/t/auto-mode-without-waypoint/21546

En relación a opción (2), vimos que de la lista desplegable de la izquierda, escogieron “Mission” y apretaron el botón “Hacer Acción”, cuando lo que había que apretar era sólo AUTO (y sin escoger “Mission”).

Lo primero que recomendamos hacer ahora es que se fijen de leer la misión desde el Hornero, para ver si la tiene cargada. Agarren una compu con Mission Planner (no la misma donde diseñaron la misión de vuelo) y hagan click en “leer WPs”. Si no la tiene cargada, a cargarla. Si sí la tiene cargada, entonces prueben hacer lo de apretar AUTO. Recuerden que el procedimiento es: armar el dron (luego de toda la safety check list claro je), con la radio control subir el dron hasta alguna altura segura (como por ej 5 metros), pasar a modo Loiter y que la copiloto aprete en el mission planner AUTO.

Si todo esto no funciona podemos probar revisar los logs del vuelo.

Igual, algunas preguntas extra:

  • Cuando conectaron el dron y comenzaron la misión, ¿vieron algún error en la pantalla de mission planner?
  • ¿Cuántas veces probaron volar la misión?
    Cuando el dron bajó, ¿lo hizo rápido o lento? ¿volvió al lugar de despegue inicial?, ¿fue “caída” o “bajada”?
  • ¿Le dieron a “save WP file” antes de hacer click en “write WP”?

salud!


#4

Gracias paz por tu respuesta. Vamos a probar todo lo que nos indicaste, lamentablemente no recordabamos lo de AUTO en vez de apretar hacer la acción. Vamos a chequear todo eso ahora a la tarde como para ponerlo en marcha.

Con respecto a tus preguntas,

  1. No hubo ningun tipo de error en la pantalla, o por lo menos que nos dieramos cuenta.
  2. Probamos dos veces, una con el TAKE OFF en la mission y otra sacandolo porque creeiamos que era algo de eso. Pero siempre cometiendo el mismo error de apretar el boton equivocado.
  3. Salvamos el WP y luego le dimo write WP

Saludos y muchas gracias


#5

Paz, de vuelta yo. Te escribo de nuevo porque seguimos con el mismo problema de no lograr hacer que el dron ande solo. Hicimos lo que nos indicaste y el dron cuando le damos la opción auto se baja como para aterrizar.

Por un lado chequeamos que el plan de vuelo estaba cargada en el dron. y le dimos auto en vez de hacer la mission

Lo que notamos es que en un momento en la pantalla de la compu decia algo como que había un problema de compass, mi pregunta es: Puede ser que este descalibrada la brujula y por eso el drone no hace la mission bien? Y si es necesario tener conexión de internet mientras que el dron vuela, porque en el campo no lo tenemos y por ahi ese sea el problema?

Si tienen alguna sugerencia de lo que podemos chequear. Por lo pronto la proxima vamos a tratar de volarlo sin ningún plan de vuelo como para ir chequeando bien todo como para ver si hay algún error que nos estamos perdiendo

Saludos

Desde ya muchas gracias

Facundo


#6

Hola Facundo, ahora estamos mirando y te escribimos asap!


#7

Hola Facundo, qué misterio!
Estuvimos leyendo un poco más, y mirando esto (https://diydrones.com/forum/topics/what-different-between-absolute-relative-terrain-alt-in-mp) se nos ocurrió que quizás esté seteada la misión para que vuele a una altura absoluta de 30m (sobre el nivel del mar), entonces al poner en auto va a querer bajar (Pergamino está a 60 aprox). No se lee bien en las imágenes, pero en la casilla desplegable que está justo arriba de la lista de waypoints, dice “Relative”, “Absolute” o “Terrain”? Para que vuele a 30 por sobre la altura en la que está el dron cuando se arma debería estar en “Relative”.


#8

Gustavo. Muchas gracias por la respuesta y tu preocupación. Exactamente estaba de manera absoluta ahí lo vamos a cambiar y probar a ver que pasa. Como dice el dicho la tercera es la vencida

Muchas gracias chicos